Talmundo - Admin Back-end down
Incident Report for Talentech
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 14:23 CET
Investigating
Dear users please note the Admin Back-End is not working , we are currently investigating the issue.
Posted Nov 15, 2024 - 13:18 CET
This incident affected: Talmundo.