Some customers may experience icons not appearing visually correct in menu tabs

Incident Report for Talentech

Resolved

Icons now appear correctly in side menu
Posted Aug 01, 2025 - 11:15 CEST

Investigating

We are currently investigating this issue.
Posted Aug 01, 2025 - 09:44 CEST
This incident affected: People Core, Talent Manager, and Talent Recruiter.